Back

Control-plane upgrades of our Cloud infrastructure

August 10, 2026 at 10:07 AM UTC

Updates

Completed

The scheduled maintenance has been completed.

August 14, 2026 at 10:00 AM UTC
In Progress

We will be performing planned upgrades of the control planes that manage our Cloud infrastructure. This is routine maintenance to keep our platform secure, reliable, and up to date.

Expected impact: none. Your databases will remain fully available throughout the maintenance window. No connection interruptions, downtime, or performance degradation are expected.

Maintenance window

Start: Monday, August 10, 2026 — 10:00 UTC
End: Monday, August 17, 2026 — 10:00 UTC

What we are doing

We are upgrading the Kubernetes control planes that orchestrate our Cloud services, region by region. Upgrades are performed with rolling, zero-downtime procedures and each region is fully validated before we proceed to the next.

What you may notice

  • Nothing, databases and connections are unaffected.

What you need to do

  • Nothing. No action is required on your side.

We will post updates here as the maintenance progresses. If you have any questions or notice anything unexpected, please reach out to support@tigerdata.com.

August 10, 2026 at 10:07 AM UTC