Back

Insights are working again

March 27, 2026 at 03:48 PM UTC Resolved after 14m

Updates

Resolved

Database was stabilised and the incident is resolved

March 27, 2026 at 04:03 PM UTC
Investigating

We are currently investigating the issue

March 27, 2026 at 03:48 PM UTC